Cisco Networking/CCENT/Switching

From Wikiversity
Jump to navigation Jump to search

This lesson covers switching.

Objectives and Skills[edit | edit source]

Objectives and skills for the switching portion of Cisco CCENT certification include:[1]

  • Identify basic switching concepts and the operation of Cisco switches
    • Collision domains
    • Broadcast domains
    • Ways to switch
      • Store
      • Forward
      • Cut through
      • CAM Table
  • Configure and verify initial switch configuration including remote access management
    • hostname
    • mgmt ip address
    • Ip default-gateway
    • local user and password
    • enable secret password
    • console and VTY logins
    • exec-timeout
    • service password encryption
    • copy run start
  • Verify network status and switch operation using basic utilities such as
    • ping
    • telnet
    • SSH

Readings[edit | edit source]

  1. Wikipedia: Network switch
  2. Cisco: LAN Switching and VLANs
  3. Cisco: Internetwork Design Guide -- LAN Switching

Multimedia[edit | edit source]

  1. YouTube: Managed vs. Unmanaged Switches - CompTIA Network+ N10-005: 2.1
  2. YouTube: Understanding Spanning Tree Protocol - CompTIA Network+ N10-005: 1.4

Examples[edit | edit source]

  1. Review Cisco Networking/CCENT/IOS Basics#Global Configuration
  2. Review Cisco Networking/CCENT/IOS Basics#Password Configuration
  3. Review Cisco Networking/CCENT/Remote Management#Line Configuration
  4. Review Cisco Networking/CCENT/Remote Management#Interface Configuration
  5. Review Cisco Networking/CCENT/Remote Management#SSH Configuration
  6. Review Cisco Networking/CCENT/IOS Basics#Configuration Management
  7. Review Cisco Networking/CCENT/Remote Management#Remote Management

Command Sequence[edit | edit source]

A command sequence to configure a switch might be similar to the following.

enable
configure terminal

hostname switch
ip domain-name example.com

interface vlan 1
ip address 192.168.1.10 255.255.255.0
ip default-gateway 192.168.1.1

username admin password secret

line console 0
login local

line aux 0
login local

line vty 0 4
login local
transport input ssh
exit

enable secret cisco
service password-encryption

crypto key generate rsa
1024
ip ssh version 2

exit
copy run start

Status[edit | edit source]

show arp[edit | edit source]

To display the entries in the Address Resolution Protocol (ARP) table, use the show ip arp command in user EXEC or privileged EXEC mode.[2]

show arp
show ip arp

show mac-address-table[edit | edit source]

Use the show mac-address-table privileged EXEC command to display the MAC address table.[3]

show mac-address-table

Activities[edit | edit source]

  1. Configure switch console password security.
    Cisco CCENT Switch.png
    1. Add an EtherSwitch router to a new GNS3 project and start the device.
    2. Open the console for the router and practice using the following commands.
      • enable
      • configure terminal
      • hostname
      • line console 0
      • password
      • login
      • exec-timeout
      • enable secret
      • service password-encryption
      • exit
    3. Verify the configuration using the following command.
      • show running-config
    4. Exit the router console session and open the console again to test the configuration.
  2. Configure switch vty username and password security.
    Cisco CCENT 2 Switches.png
    1. Add a second EtherSwitch router to the project above and start the device.
    2. Add a link to connect the following.
      • ESW1 FastEthernet1/1 <-> ESW2 FastEthernet1/1
    3. Set the following IP addresses and subnet masks.
      • ESW1 VLAN 1: 192.168.1.1 255.255.255.0
      • ESW2 VLAN 1: 192.168.1.2 255.255.255.0
    4. Open the console for both routers and practice using the following commands.
      • enable
      • configure terminal
      • username
      • line vty 0 4
      • login local
      • exit
      • interface vlan 1
      • ip address
      • no shutdown
      • ip default-gateway
    5. Verify the configuration using the following command on both routers.
      • show running-config
      • ping
      • show arp
      • show mac-address-table
    6. Test the configuration using the following command to remotely manage one router from the other.
      • telnet
  3. Configure switch SSH access.
    Cisco CCENT 2 Switches.png
    1. Use the routers from above and practice using the following commands on both routers.
      • enable
      • configure terminal
      • hostname
      • ip domain-name
      • crypto key generate rsa
      • ip ssh version 2
      • line vty 0 4
      • transport input ssh
    2. Verify the configuration using the following command on both routers.
      • show running-config
    3. Test the configuration using the following command to verify that telnet access is no longer supported.
      • telnet
    4. Test the configuration using the following command to remotely manage one router from the other.
      • ssh
    5. Save the configuration using the following command.
      • copy running-config startup-config

Lesson Summary[edit | edit source]

  • A network switch is a computer networking device that connects devices together on a computer network, by using frame switching to receive, process and forward data to the destination device.[4]
  • A network switch forwards data only to one or multiple devices that need to receive it, rather than broadcasting the same data out of each of its ports.[5]
  • Switches forward frames through one of three methods: store and forward, cut through, and fragment free.[6]
  • Store and forward buffers and verifies each frame before forwarding it.[7]
  • Cut through starts forwarding after the frame's destination address is received.[8]
  • Fragment free checks the first 64 bytes of the frame, to detect collision errors before forwarding occurs.[9]
  • Some switches may support adaptive switching by automatically selecting between the three methods.[10]
  • Switch global configuration is similar to router global configuration, including the enable, disable, configure terminal, exit, hostname, and ip domain-name commands.
  • Switch password configuration is similar to router password configuration, including the password, login, username, login local, exec-timeout, enable password, enable secret, and service password-encryption commands.
  • Switch line configuration is similar to router line configuration, including the show line and line commands.
  • Switch interface configuration is similar to router interface configuration, including the show ip interface, show ip interface brief, interface, ip address, shutdown and no shutdown commands.
  • Switch SSH configuration is similar to router SSH configuration, including the crypto key generate rsa, ip ssh version, and transport input commands.
  • Switch configuration management is similar to router configuration management, including the show running-config, show startup-config, copy, erase, and reload commands.
  • Switch remote management is similar to router remote management, including the telnet and ssh commands.
  • Switch status is tested similar to router status, including the ping and traceroute commands.
  • To enable remote management of a switch, assign an IP address to the management VLAN interface, which by default is VLAN 1.[11]
  • To define a default gateway (router) when IP routing is disabled, use the ip default-gateway command in global configuration mode.[12]
  • To display the entries in the Address Resolution Protocol (ARP) table, use the show ip arp command in user EXEC or privileged EXEC mode.[13]
  • Use the show mac-address-table privileged EXEC command to display the MAC address table.[14]

Key Terms[edit | edit source]

autonegotiation
An Ethernet procedure by which two connected devices choose common transmission parameters, such as speed, duplex mode, and flow control.[15]
flooding
Sending incoming unknown-destination frames out on all ports.[16]
Spanning Tree Protocol (STP)
A network protocol that ensures a loop-free topology for Ethernet networks and allows a network design to include spare (redundant) links to provide automatic backup paths if an active link fails, without the danger of bridge loops, or the need for manual enabling or disabling of these backup links.[17]

Review Questions[edit | edit source]

Enable JavaScript to hide answers.
Click on a question to see the answer.
  1. A network switch is _____.
    A network switch is a computer networking device that connects devices together on a computer network, by using frame switching to receive, process and forward data to the destination device.
  2. A network switch forwards data _____.
    A network switch forwards data only to one or multiple devices that need to receive it, rather than broadcasting the same data out of each of its ports.
  3. Switches forward frames through one of three methods: _____, _____, and _____.
    Switches forward frames through one of three methods: store and forward, cut through, and fragment free.
  4. Store and forward _____.
    Store and forward buffers and verifies each frame before forwarding it.
  5. Cut through _____.
    Cut through starts forwarding after the frame's destination address is received.
  6. Fragment free _____.
    Fragment free checks the first 64 bytes of the frame to detect collision errors before forwarding occurs.
  7. Some switches may support adaptive switching by _____.
    Some switches may support adaptive switching by automatically selecting between the three forwarding methods.
  8. Switch global configuration is similar to router global configuration, including the _____ commands.
    Switch global configuration is similar to router global configuration, including the enable, disable, configure terminal, exit, hostname, and ip domain-name commands.
  9. Switch password configuration is similar to router password configuration, including the _____ commands.
    Switch password configuration is similar to router password configuration, including the password, login, username, login local, exec-timeout,enable password, enable secret, and service password-encryption commands.
  10. Switch line configuration is similar to router line configuration, including the _____ commands.
    Switch line configuration is similar to router line configuration, including the show line and line commands.
  11. Switch interface configuration is similar to router interface configuration, including the _____ commands.
    Switch interface configuration is similar to router interface configuration, including the show ip interface, show ip interface brief, interface,ip address, shutdown and no shutdown commands.
  12. Switch SSH configuration is similar to router SSH configuration, including the _____ commands.
    Switch SSH configuration is similar to router SSH configuration, including the crypto key generate rsa, ip ssh version, and transport input commands.
  13. Switch configuration management is similar to router configuration management, including the _____ commands.
    Switch configuration management is similar to router configuration management, including the show running-config, show startup-config, copy, erase, and reload commands.
  14. Switch remote management is similar to router remote management, including the _____ commands.
    Switch remote management is similar to router remote management, including the telnet and ssh commands.
  15. Switch status is tested similar to router status, including the _____ commands.
    Switch status is tested similar to router status, including the ping and traceroute commands.
  16. To enable remote management of a switch, _____.
    To enable remote management of a switch, assign an IP address to the management VLAN interface, which by default is VLAN 1.
  17. To define a default gateway (router) when IP routing is disabled, use _____.
    To define a default gateway (router) when IP routing is disabled, use the ip default-gateway command in global configuration mode.
  18. To display the entries in the Address Resolution Protocol (ARP) table, use _____.
    To display the entries in the Address Resolution Protocol (ARP) table, use the show ip arp command in user EXEC or privileged EXEC mode.
  19. Use the _____ command to display the MAC address table.
    Use the show mac-address-table privileged EXEC command to display the MAC address table.

Assessments[edit | edit source]

See Also[edit | edit source]

References[edit | edit source]

Progress-1000.svg Completion status: this resource is considered to be complete.