Cisco Networking/CCENT/Network Services

From Wikiversity
Jump to navigation Jump to search

This lesson covers network services, including DHCP, DNS, NTP, and NAT.

Objectives and Skills[edit | edit source]

Objectives and skills for the network services portion of Cisco CCENT certification include:[1]

  • Configure and verify DHCP (IOS router)
    • Configuring router interfaces to use DHCP
    • DHCP options (Basic overview and functionality)
    • Excluded addresses
    • Lease time
  • Configure and verify NTP as a client
  • Identify the basic operation of NAT
    • Purpose
    • Pool
    • Static
    • 1 to 1
    • Overloading
    • Source addressing
    • One-way NAT
  • Configure and verify NAT for given network requirements

Readings[edit | edit source]

  1. Wikipedia: Dynamic Host Configuration Protocol
  2. Wikipedia: DHCPv6
  3. Wikipedia: Domain Name System
  4. Wikipedia: Network Time Protocol
  5. Wikipedia: Network address translation
  6. Cisco: Configuring the Cisco IOS DHCP Client
  7. Cisco: Configuring DNS on Cisco Routers
  8. Cisco: Configuring Network Address Translation
  9. Networking Signal: DHCP Dora Process

Multimedia[edit | edit source]

  1. YouTube: DHCP Addressing Overview - CompTIA Network+ N10-005: 2.3
  2. YouTube: An Overview of DNS - CompTIA Network+ N10-005: 1.7
  3. YouTube: Configuring a DHCP Server on a Cisco Router
  4. YouTube: Configuring NAT (PAT) on Cisco Routers
  5. Cisco: Internet Connections with NAT and PAT
  6. YouTube: GNS3 Tutorial - Connecting GNS3 Routers to the Internet in Windows 7

Examples[edit | edit source]

DHCP Client Configuration[edit | edit source]

ip address dhcp[edit | edit source]

To assign a dynamic IP address to an interface, use the ip address dhcp command.[2]

ip address dhcp

release dhcp[edit | edit source]

To release a dynamic IP address, use the release dhcp command.[3]

release dhcp <interface>

renew dhcp[edit | edit source]

To renew a dynamic IP address, use the renew dhcp command.[4]

renew dhcp <interface>

Command Sequence[edit | edit source]

A command sequence to assign a dynamic ip address would be similar to the following.

enable
configure terminal
interface fastethernet0/1
ip address dhcp
no shutdown
exit
exit

show ip interface brief

exit

A command sequence to release and renew a dynamic ip address would be similar to the following.

enable
release dhcp fastethernet0/1
show ip interface brief

renew dhcp fastethernet0/1
show ip interface brief

exit

DNS Configuration[edit | edit source]

ip domain lookup[edit | edit source]

To enable IP Domain Name System (DNS)-based hostname-to-address translation, use the ip domain lookup command in global configuration mode.[5]

ip domain lookup

ip name-server[edit | edit source]

To specify one or more hosts (up to six) that can function as a name server to supply name information for the DNS, use the ip name-server command in global configuration mode.[6]

ip name-server <ip address> [<ip address>] [<ip address>] [<ip address>] [<ip address>] [<ip address>]

ip dns server[edit | edit source]

To enable the Domain Name System (DNS) server on a router, use the ip dns server command in global configuration mode.[7]

ip dns server

Command Sequence[edit | edit source]

A command sequence to configure the DNS service and verify DNS host name lookup would be similar to the following.

enable
configure terminal
ip domain lookup
ip name-server 8.8.8.8 8.8.4.4
ip dns server
exit

ping en.wikiversity.org
exit

DHCP Server Configuration[edit | edit source]

ip dhcp excluded-address[edit | edit source]

To specify the IP addresses that the DHCP Server should not assign to clients, use the ip dhcp excluded-address command in global configuration mode.[8]

ip dhcp excluded-address <start> <end>

ip dhcp pool[edit | edit source]

To configure the DHCP address pool name and enter DHCP pool configuration mode, use the ip dhcp pool command in global configuration mode.[9]

ip dhcp pool <name>

network[edit | edit source]

To configure a subnet and mask for the newly created DHCP address pool, use the network command in DHCP pool configuration mode.[10]

network <network> [<mask> | </prefix>]

default-router[edit | edit source]

To specify a default router for a DHCP client, use the default-router command in DHCP pool configuration mode.[11]

default-router <address> [<address2>] ... [<address8>]

domain-name[edit | edit source]

To configure a domain name string for the client, use the domain-name command in DHCP pool configuration mode.[12]

domain-name <domain>

dns-server[edit | edit source]

To configure the DNS IP servers that are available to a DHCP client, use the dns-server command in DHCP pool configuration mode.[13]

dns-server <address> [<address2>] ... [<address8>]

lease[edit | edit source]

By default, each IP address assigned by a DHCP Server comes with a one-day lease. To change the lease value, use the lease command in DHCP pool configuration mode. [14]

lease [<days> [<hours>] [<minutes>] | infinite]

show ip dhcp[edit | edit source]

To display DHCP Server information, use the following commands in EXEC mode, as needed:

show ip dhcp pool <name>
show ip dhcp binding
show ip dhcp server statistics

Command Sequence[edit | edit source]

A command sequence to configure a DHCP server would be similar to the following.

enable
configure terminal
ip dhcp excluded-address 192.168.1.1 192.168.1.10
ip dhcp pool local
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
domain-name example.com
dns-server 192.168.1.1
lease 1
exit
exit

show ip dhcp pool local
show ip dhcp binding
show ip dhcp server statistics
exit

NTP Configuration[edit | edit source]

show clock[edit | edit source]

To display the time and date from the system software clock, use the show clock EXEC command.[15]

show clock

ntp server[edit | edit source]

To allow the software clock to be synchronized by a Network Time Protocol (NTP) time server, use the ntp server command in global configuration mode.[16]

ntp server <ip address> | <hostname>

show ntp associations[edit | edit source]

To show the status of Network Time Protocol (NTP) associations, use the show ntp associations EXEC command.[17]

show ntp associations

Command Sequence[edit | edit source]

A command sequence to configure and verify an NTP server would be similar to the following.

enable
show clock

configure terminal
ip domain lookup
ntp server us.pool.ntp.org
exit

show clock
show ntp associations
exit

NAT Configuration[edit | edit source]

ip nat[edit | edit source]

To designate that traffic originating from or destined for the interface is subject to Network Address Translation ( NAT), use the ip nat command in interface configuration mode.[18]

ip nat <inside | outside>
ip nat inside
ip nat outside

ip nat inside source[edit | edit source]

To enable Network Address Translation (NAT) of the inside source address, use the ip nat inside source command in global configuration mode.[19]

Static NAT
ip nat inside source static <local-ip> <global-ip>
ip nat inside source static 192.168.1.11 10.11.22.33

Port Static NAT
ip nat inside source static <tcp | udp> <local-ip> <local-port> <global-ip> <global-port>
ip nat inside source static tcp 192.168.1.11 80 172.16.11.1 80

Dynamic NAT
ip nat inside source list <access-list-number> interface <interface> [overload]
ip nat inside source list 1 interface FastEthernet0/1 overload

Dynamic NAT Pool
ip nat inside source list <access-list-number> pool <name>
ip nat inside source list 1 pool global

ip nat pool[edit | edit source]

To define a pool of IP addresses for Network Address Translation (NAT) translations, use the ip nat pool command in global configuration mode.[20]

ip nat pool <name> <start-ip> <end-ip> netmask <netmask>
ip nat pool <name> <start-ip> <end-ip> prefix-length <prefix-length>
ip nat pool global 10.11.22.33 10.11.22.38 netmask 255.255.255.248
ip nat pool global 10.11.22.33 10.11.22.38 prefix-length 29

access list[edit | edit source]

To define a standard IP access list, use the standard version of the access-list command in global configuration mode.[21]

access-list <access-list-number> <deny | permit> <source> <source-wildcard>
access-list 1 permit 192.168.1.0 0.0.0.255

Command Sequence[edit | edit source]

A command sequence to configure dynamic NAT/PAT would be similar to the following.

enable
configure terminal

interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
exit

interface FastEthernet0/1
ip address dhcp
ip nat outside
exit

ip nat inside source list 1 interface FastEthernet0/1 overload
access-list 1 permit 192.168.1.0 0.0.0.255
exit

show running-config
exit

Activities[edit | edit source]

  1. Configure dynamic client addressing.
    Cisco CCENT Cloud Router.png
    1. Add a cloud and a router to a new GNS3 project and start the devices.
    2. Configure the cloud and add a Generic Ethernet NIO interface matching your host computer's Ethernet interface.
    3. Add a link to connect the following.
      • R1 FastEthernet0/1 <-> Cloud1 Ethernet connection
    4. Open the console for the router and practice using the following commands.
      • enable
      • configure terminal
      • interface
      • ip address dhcp
      • no shutdown
      • exit
    5. Verify the configuration using the following commands.
      • show ip interface brief
      • show ip default-gateway
  2. Configure host name resolution.
    Cisco CCENT Cloud Router.png
    1. Use the router from above and practice using the following commands.
      • enable
      • configure terminal
      • ip domain lookup
      • ip name-server
      • ip dns server
      • exit
    2. Verify the configuration using the following command.
      • ping en.wikiversity.org.
  3. Configure an NTP server.
    Cisco CCENT Cloud Router.png
    1. Use the router from above and practice using the following commands.
      • enable
      • show clock
      • configure terminal
      • ntp server
      • exit
    2. Verify the configuration using the following commands.
      • show ntp associations.
      • show clock.
  4. Configure a router as a DHCP server.
    Cisco CCENT Cloud Router PC.png
    1. Use the router from above and practice using the following commands.
      • enable
      • configure terminal
      • ip dhcp excluded-address
      • ip dhcp pool local
      • network
      • default-router
      • domain-name
      • dns-server
      • lease
      • exit
    2. Verify the configuration using the following commands.
      • show ip dhcp pool local
      • show ip dhcp binding
      • show ip dhcp server statistics
    3. Test the configuration by adding a VCPS PC to the project.
    4. Add a link to connect the following.
      • R1 FastEthernet0/0 <-> PC1 Ethernet0
    5. Open the console for PC1. Set the IP address for PC1 using the following commands.
      • ip dhcp
      • ping
  5. Configure a router to provide NAT/PAT.
    Cisco CCENT Cloud Router PC.png
    1. Use the router and PC from above and practice using the following commands.
      • enable
      • configure terminal
      • interface
      • ip nat
      • access-list
      • ip nat inside source
      • exit
    2. Verify the configuration using the following commands.
      • show running-config
    3. Open the console for PC1 and test the configuration using the following command.
      • ping 8.8.8.8

Lesson Summary[edit | edit source]

  • Dynamic Host Configuration Protocol is used by hosts to request Internet Protocol parameters from a network server.[22]
  • DHCPv4 operations fall into four basic phases: IP discovery, IP lease offer, IP request, and IP lease acknowledgement. These points are often abbreviated as DORA (Discovery, Offer, Request, Acknowledgement).[23]
  • DHCPv4 options provided to clients include subnet mask, router (default gateway), domain name server, domain name, lease time, renewal time (T1), rebinding time (T2), and others.[24]
  • Network links without a DHCP server can use DHCP relay agents to receive messages from DHCP clients and forward them to DHCP servers. DHCP servers send responses back to the relay agent, and the relay agent then sends these responses to the DHCP client on the local network link.[25]
  • DHCPv6 operations are similar to DHCPv4, but are described as Solicit, Advertise, Request, and Reply.[26] Renewals are processed with Renew and Reply.[27]
  • Domain Name System (DNS) is a hierarchical distributed naming system for computers, services, or any resource connected to the Internet or a private network.[28]
  • DNS distributes the responsibility of assigning domain names and mapping those names to IP addresses. Authoritative name servers are assigned to be responsible for their particular domains, and in turn can assign other authoritative name servers for their sub-domains.[29]
  • Caching DNS servers cache DNS queries and perform recursive queries to improve efficiency, reduce DNS traffic across the Internet, and increase performance in end-user applications.[30]
  • Network Time Protocol (NTP) is a networking protocol for clock synchronization between computer systems over packet-switched, variable-latency data networks.[31]
  • NTP is intended to synchronize all participating computers to within a few milliseconds of Coordinated Universal Time (UTC).[32]
  • Network address translation (NAT) is a methodology of remapping one IP address space into another by modifying network address information in Internet Protocol (IP) datagram packet headers while they are in transit across a traffic routing device.[33]
  • To assign a dynamic IP address to an interface, use the ip address dhcp command.[34]
  • To release a dynamic IP address, use the release dhcp command.[35]
  • To renew a dynamic IP address, use the renew dhcp command.[36]
  • To enable IP Domain Name System (DNS)-based hostname-to-address translation, use the ip domain lookup command in global configuration mode.[37]
  • To specify one or more hosts (up to six) that can function as a name server to supply name information for the DNS, use the ip name-server command in global configuration mode.[38]
  • To enable the Domain Name System (DNS) server on a router, use the ip dns server command in global configuration mode.[39]
  • To specify the IP addresses that the DHCP Server should not assign to clients, use the ip dhcp excluded-address command in global configuration mode.[40]
  • To configure the DHCP address pool name and enter DHCP pool configuration mode, use the ip dhcp pool command in global configuration mode.[41]
  • To configure a subnet and mask for the newly created DHCP address pool, use the network command in DHCP pool configuration mode.[42]
  • To specify a default router for a DHCP client, use the default-router command in DHCP pool configuration mode.[43]
  • To configure a domain name string for the client, use the domain-name command in DHCP pool configuration mode.[44]
  • To configure the DNS IP servers that are available to a DHCP client, use the dns-server command in DHCP pool configuration mode.[45]
  • To change the default DHCP lease value, use the lease command in DHCP pool configuration mode.[46]
  • To display DHCP Server information, use the commands show ip dhcp pool <name>, show ip dhcp binding, and show ip dhcp server statistics in EXEC mode, as needed.
  • To display the time and date from the system software clock, use the show clock EXEC command.[47]
  • To allow the software clock to be synchronized by a Network Time Protocol (NTP) time server, use the ntp server command in global configuration mode.[48]
  • To show the status of Network Time Protocol (NTP) associations, use the show ntp associations EXEC command.[49]
  • To designate that traffic originating from or destined for the interface is subject to Network Address Translation ( NAT), use the ip nat command in interface configuration mode.[50]
  • To enable Network Address Translation (NAT) of the inside source address, use the ip nat inside source command in global configuration mode.[51]
  • To define a pool of IP addresses for Network Address Translation (NAT) translations, use the ip nat pool command in global configuration mode.[52]
  • To define a standard IP access list, use the standard version of the access-list command in global configuration mode.[53]

Key Terms[edit | edit source]

inside global
A legitimate IP address assigned by the NIC or service provider that represents one or more inside local IP addresses to the outside world.[54]
inside local
The IP address assigned to a host on the inside network.[55]
NAT overload
Allows NAT to translate multiple inside devices to a single address in the pool.[56]
outside global
The IP address assigned to a host on the outside network by the host owner.[57]
outside local
The IP address of an outside host as it appears to the inside network.[58]
PAT
Address translation using only one or a few external addresses to support multiple internal addresses. Also see NAT overload.[59]
stateful DHCPv6
Enables DHCP servers to pass configuration parameters, such as IPv6 network addresses, to IPv6 nodes.[60]
stateless DHCPv6
Uses stateless autoconfiguration (SLAAC) to assign one or more IPv6 addresses to an interface, while it utilizes DHCPv6 to receive additional parameters which may not be available through SLAAC.[61]
Stateless Address Autoconfiguration (SLAAC)
A method by which a node automatically creates a link-local address with the prefix fe80::/64 on each IPv6-enabled interface, even if globally routable addresses are manually configured or obtained through configuration protocols.[62]

Review Questions[edit | edit source]

Enable JavaScript to hide answers.
Click on a question to see the answer.
  1. Dynamic Host Configuration Protocol is used by hosts to _____.
    Dynamic Host Configuration Protocol is used by hosts to request Internet Protocol parameters from a network server.
  2. DHCPv4 operations fall into four basic phases: _____. These points are often abbreviated as _____.
    DHCPv4 operations fall into four basic phases: IP discovery, IP lease offer, IP request, and IP lease acknowledgement. These points are often abbreviated as DORA (Discovery, Offer, Request, Acknowledgement).
  3. DHCPv4 options provided to clients include _____.
    DHCPv4 options provided to clients include subnet mask, router (default gateway), domain name server, domain name, lease time, renewal time (T1), rebinding time (T2), and others.
  4. Network links without a DHCP server can use _____ to receive messages from DHCP clients and forward them to DHCP servers.
    Network links without a DHCP server can use DHCP relay agents to receive messages from DHCP clients and forward them to DHCP servers. DHCP servers send responses back to the relay agent, and the relay agent then sends these responses to the DHCP client on the local network link.
  5. DHCPv6 operations are similar to DHCPv4, but are described as _____.
    DHCPv6 operations are similar to DHCPv4, but are described as Solicit, Advertise, Request, and Reply.[26] Renewals are processed with Renew and Reply.
  6. Domain Name System (DNS) is _____.
    Domain Name System (DNS) is a hierarchical distributed naming system for computers, services, or any resource connected to the Internet or a private network.
  7. DNS distributes _____. Authoritative name servers are _____.
    DNS distributes the responsibility of assigning domain names and mapping those names to IP addresses. Authoritative name servers are assigned to be responsible for their particular domains, and in turn can assign other authoritative name servers for their sub-domains.
  8. Caching DNS servers _____.
    Caching DNS servers cache DNS queries and perform recursive queries to improve efficiency, reduce DNS traffic across the Internet, and increase performance in end-user applications.
  9. Network Time Protocol (NTP) is _____.
    Network Time Protocol (NTP) is a networking protocol for clock synchronization between computer systems over packet-switched, variable-latency data networks.
  10. NTP is intended to synchronize all participating computers to _____.
    NTP is intended to synchronize all participating computers to within a few milliseconds of Coordinated Universal Time (UTC).
  11. Network address translation (NAT) is _____.
    Network address translation (NAT) is a methodology of remapping one IP address space into another by modifying network address information in Internet Protocol (IP) datagram packet headers while they are in transit across a traffic routing device.
  12. To assign a dynamic IP address to an interface, use _____.
    To assign a dynamic IP address to an interface, use the ip address dhcp command.
  13. To release a dynamic IP address, use _____.
    To release a dynamic IP address, use the release dhcp command.
  14. To renew a dynamic IP address, use _____.
    To renew a dynamic IP address, use the renew dhcp command.
  15. To enable IP Domain Name System (DNS)-based hostname-to-address translation, use _____.
    To enable IP Domain Name System (DNS)-based hostname-to-address translation, use the ip domain lookup command in global configuration mode.
  16. To specify one or more hosts (up to six) that can function as a name server to supply name information for the DNS, use _____.
    To specify one or more hosts (up to six) that can function as a name server to supply name information for the DNS, use the ip name-server command in global configuration mode.
  17. To enable the Domain Name System (DNS) server on a router, use _____.
    To enable the Domain Name System (DNS) server on a router, use the ip dns server command in global configuration mode.
  18. To specify the IP addresses that the DHCP Server should not assign to clients, use _____.
    To specify the IP addresses that the DHCP Server should not assign to clients, use the ip dhcp excluded-address command in global configuration mode.
  19. To configure the DHCP address pool name and enter DHCP pool configuration mode, use _____.
    To configure the DHCP address pool name and enter DHCP pool configuration mode, use the ip dhcp pool command in global configuration mode.
  20. To configure a subnet and mask for the newly created DHCP address pool, use _____.
    To configure a subnet and mask for the newly created DHCP address pool, use the network command in DHCP pool configuration mode.
  21. To specify a default router for a DHCP client, use _____.
    To specify a default router for a DHCP client, use the default-router command in DHCP pool configuration mode.
  22. To configure a domain name string for the client, use _____.
    To configure a domain name string for the client, use the domain-name command in DHCP pool configuration mode.
  23. To configure the DNS IP servers that are available to a DHCP client, use _____.
    To configure the DNS IP servers that are available to a DHCP client, use the dns-server command in DHCP pool configuration mode.
  24. To change the default DHCP lease value, use _____.
    To change the default DHCP lease value, use the lease command in DHCP pool configuration mode.
  25. To display DHCP Server information, use the commands _____, _____, and _____ in EXEC mode, as needed.
    To display DHCP Server information, use the commands show ip dhcp pool <name>, show ip dhcp binding, and show ip dhcp server statistics in EXEC mode, as needed.
  26. To display the time and date from the system software clock, use _____.
    To display the time and date from the system software clock, use the show clock EXEC command.
  27. To allow the software clock to be synchronized by a Network Time Protocol (NTP) time server, use _____.
    To allow the software clock to be synchronized by a Network Time Protocol (NTP) time server, use the ntp server command in global configuration mode.
  28. To show the status of Network Time Protocol (NTP) associations, use _____.
    To show the status of Network Time Protocol (NTP) associations, use the show ntp associations EXEC command.
  29. To designate that traffic originating from or destined for the interface is subject to Network Address Translation ( NAT), use _____.
    To designate that traffic originating from or destined for the interface is subject to Network Address Translation ( NAT), use the ip nat command in interface configuration mode.
  30. To enable Network Address Translation (NAT) of the inside source address, use _____.
    To enable Network Address Translation (NAT) of the inside source address, use the ip nat inside source command in global configuration mode.
  31. To define a pool of IP addresses for Network Address Translation (NAT) translations, use _____.
    To define a pool of IP addresses for Network Address Translation (NAT) translations, use the ip nat pool command in global configuration mode.
  32. To define a standard IP access list, use _____.
    To define a standard IP access list, use the standard version of the access-list command in global configuration mode.

Assessments[edit | edit source]

See Also[edit | edit source]

References[edit | edit source]

Progress-1000.svg Completion status: this resource is considered to be complete.
  1. Cisco: ICND1 Exam Topics
  2. Cisco: Configuring the Cisco IOS DHCP Client
  3. Cisco: Configuring the Cisco IOS DHCP Client
  4. Cisco: Configuring the Cisco IOS DHCP Client
  5. Cisco: IOS IP Addressing Services Command Reference
  6. Cisco: IOS IP Configuration Guide
  7. Cisco: IOS Network Management Command Reference
  8. Cisco: Configuring DHCP
  9. Cisco: Configuring DHCP
  10. Cisco: Configuring DHCP
  11. Cisco: Configuring DHCP
  12. Cisco: Configuring DHCP
  13. Cisco: Configuring DHCP
  14. Cisco: Configuring DHCP
  15. Cisco: IOS Configuration Fundamentals Command Reference
  16. Cisco: IOS Configuration Fundamentals Command Reference
  17. Cisco: IOS Configuration Fundamentals Command Reference
  18. Cisco: IOS IP Addressing Services Command Reference
  19. Cisco: IOS IP Addressing Services Command Reference
  20. Cisco: IOS IP Addressing Services Command Reference
  21. Cisco: IOS IP Command Reference
  22. Wikipedia: Dynamic Host Configuration Protocol
  23. Wikipedia: Dynamic Host Configuration Protocol
  24. Wikipedia: Dynamic Host Configuration Protocol
  25. Wikipedia: Dynamic Host Configuration Protocol
  26. Wikipedia: DHCPv6
  27. RFC 3315
  28. Wikipedia: Domain Name System
  29. Wikipedia: Domain Name System
  30. Wikipedia: Domain Name System#Recursive and caching name server
  31. Wikipedia: Network Time Protocol
  32. Wikipedia: Network Time Protocol
  33. Wikipedia: Network address translation
  34. Cisco: Configuring the Cisco IOS DHCP Client
  35. Cisco: Configuring the Cisco IOS DHCP Client
  36. Cisco: Configuring the Cisco IOS DHCP Client
  37. Cisco: IOS IP Addressing Services Command Reference
  38. Cisco: IOS IP Configuration Guide
  39. Cisco: IOS Network Management Command Reference
  40. Cisco: Configuring DHCP
  41. Cisco: Configuring DHCP
  42. Cisco: Configuring DHCP
  43. Cisco: Configuring DHCP
  44. Cisco: Configuring DHCP
  45. Cisco: Configuring DHCP
  46. Cisco: Configuring DHCP
  47. Cisco: IOS Configuration Fundamentals Command Reference
  48. Cisco: IOS Configuration Fundamentals Command Reference
  49. Cisco: IOS Configuration Fundamentals Command Reference
  50. Cisco: IOS IP Addressing Services Command Reference
  51. Cisco: IOS IP Addressing Services Command Reference
  52. Cisco: IOS IP Addressing Services Command Reference
  53. Cisco: IOS IP Command Reference
  54. Cisco: NAT Local and Global Definitions
  55. Cisco: NAT Local and Global Definitions
  56. Cisco: Configuring Network Address Translation
  57. Cisco: NAT Local and Global Definitions
  58. Cisco: NAT Local and Global Definitions
  59. Cisco: IOS Network Address Translation Overivew
  60. Cisco DHCPv6 Based IPv6 Access Services
  61. Cisco DHCPv6 Based IPv6 Access Services
  62. Wikipedia: IPv6 address#Stateless address autoconfiguration