macOS
Appearance
macOS (previously Mac OS X, then OS X) is a series of graphical operating systems developed and marketed by Apple Inc. since 2001. It is the primary operating system for Apple's Mac family of computers.[1]. zsh is the default shell replacing Bash since October 2019.
Resources
[edit | edit source]- How to create a folder
- pkgutil software package management tool
- homebrew software package management tool
- Install additional software using Homebrew package management software and
brew
command. - launchd init and operating system service management daemon for MacOS. Path:
/Library/LaunchAgents/
[2]
sudo launchctl load YOUR_NEW_SERVICE.plist sudo launchctl start com.XXXX.YOUR_NEW_SERVICE
- Create a user from command line:
sysadminctl -addUser YOUR_USERNAME
- Display your DNS configuration in macOS running:
scutil --dns
- Sleep your macOS from command line:
pmset sleepnow
- Enable ssh from command line:
- Enable:
sudo systemsetup -setremotelogin on
[3] - Disable:
sudo systemsetup -setremotelogin off
- Status:
sudo systemsetup -getremotelogin
Commands
[edit | edit source]defaults
system_profiler
ifconfig
networksetup
hdiutil
disk image manipulation tool- AppleScript:
osascript
. Example:osascript -e 'display notification "Lorem ipsum dolor sit amet" with title "Title"'
pbcopy
[4] Copy to clipboard[5]mdfind
finds files matching a given query. Similar tolocate
command in Linux.
See Also
[edit | edit source]References
[edit | edit source]- ↑ Wikipedia: macOS
- ↑ https://developer.apple.com/library/archive/documentation/MacOSX/Conceptual/BPSystemStartup/Chapters/CreatingLaunchdJobs.html
- ↑ http://osxdaily.com/2016/08/16/enable-ssh-mac-command-line/
- ↑ https://ss64.com/osx/pbcopy.html
- ↑ https://www.cnet.com/how-to/how-to-pipe-command-output-to-the-clipboard-in-os-x/
Educational level: this is a secondary education resource. |