Grassroots media training/KKFI/Audacity

From Wikiversity
Jump to navigation Jump to search
An icon with headphones that have a compression wave between them
Audacity audio editor is high quality free and open-source software for editing audio files.
This article provides documentation for a class on Audacity (audio editor) to be taught by KKFI, Kansas City Community Radio, for volunteers and other interested parties.
It is on Wikiversity to invite anyone interested to contribute in any way they feel may help anyone interested in teaching a similar class.

Learning objectives of this training module: After following the instructions in this article, the reader should be able to do the following:

  • Download and install Audacity on a computer of their choice (running Windows, macOS or Linux).
  • Read a standard audio file into Audacity or extract the audio from a standard video file.
  • Delete an undesired part of the recording.
  • Increase and decrease the volume of selected portions of an audio file.
  • Cut pieces from different audio files and assemble them in a desired order.
  • Export the result in standard MP3 format.

1. Download and install[edit]

The Wikipedia article on Audacity (audio editor) says the web site for the software is audacityteam.org. As of 2019-09-07 that landing page includes a “Download” drop-down menu near the upper left and a button in the lower left to “Download Audacity”.

You will likely need administrator rights on the computer in question, so you may wish to check that first.

Click on either “Download” menu and select the version for the computer upon which you want to install it. Then follow the instructions.

1.1. for Windows[edit]

Go to audacityteam.org. That landing page displays “Download” prominently in two places: The third dropdown menu from the upper left and a button further down on the left.

Clicking “Windows” under either one should take you to audacityteam.org/download/windows.

This provides two “Recommended Downloads”:

  • Audacity 2.3.2 installer (includes user manual)
  • Audacity 2.3.2 zip file – smaller download (without user manual)

(The version numbers will doubtless increase with time.) Select either one. It will then take you to [https://www.fosshub.com/Audacity.html fosshub.com/Audacity.html]. The first two options there will likely be as follows:

  • Audacity Windows Installer
  • Audacity Windows Zip

Clicking either should present you with an option to “Save File” plus other options that vary depending on which version of Windows and which browser you are using.

Under some version of Windows and the browser you use, you may have an option to “Run”. If so, select that.

If you do not get a “Run” option, but the download seems complete, find the Windows Explorer and look for a “Downloads” folder. If you see that, click on it: It should contain “audacity-win-2.3.2.exe” (or “audacity-win-2.3.2.zip”). Double click that.

If you don't see that, look for something like “C:”. That should contain a folder “Users”. (If you do not see that, click on the triangle to the left of that to expand the contents of “C:”.)

Under “Users”, there should be a folder with the name of a “person”, being the “person” who is officially logged into that computer at that time. Click on that (or click in the triangle to the left) . That should contain a folder named “Downloads”. And that should contain “audacity-win-2.3.3.exe” or “audacity-win-2.3.3.zip” or something like that. Double click that.

Following the instructions from there should install the latest version of Audacity. (If Audacity is already installed on this computer, this procedure should replace that with the latest version.)

Optional extension required to read Apple QuickTime .MOV files[edit]

As of 2019-09-12 the software that comes standard on an iPhone includes the ability to make movies in the Apple QuickTime .MOV format. By contrast, it is not as easy to find free software for an iPhone that will produce an audio file of an arbitrary length. Some applications seem to work fine with a short test but can turn off without warning before going over 60 minutes. This is unacceptable.

Fortunately a user can make a movie and extract the audio from it using Audacity 2.3.2, the recommended version as of 2019-09-12, but not without additional libraries that must be installed separately, because of different copyright restrictions in different countries. Reading this and other less common formats in Audacity on a Mac requires the installation of FFmpeg.

To install FFmpeg for Audacity, https://lame.buanzo.org/#lamewindl provides options to download either a ZIP or exe file. The ZIP file did not work for me, but the exe option did.

Specifically, click on Click “ffmpeg-win-2.2.2.exe” near the end of the lines reading, “FFmpeg 2.2.2 Binary for Windows, compatible with Audacity 2.0.6 and later (please update, or use v0.6.2 below) ffmpeg-win-2.2.2.exe - (SHA256 SUM here)”. Then click “Save File” (for Windows 7) or “Save” (for Windows 10).

On Windows 10 I was given an option to “Run” the file when it finished downloading; I clicked “Run” there. On Windows 7, I seemed to have to go to Windows Explorer, open “Computer”, then open “C:”, then “Users”. Under “Users” there seems to be subfolders for each authorized “User” including a “Public” folder for the “administrator”. Click the folder corresponding to the identity under which you are logged in. That's probably NOT “Public”. In many cases, there is only one other “User”, so this is easy. If there are multiple and you want to make this available to all Users, then you should be logged in as “Administrator” for this installation. In that case, you probably want the “Public” folder.

If you select the correct “User”, the newest file in its “Downloads” folder should be “ffmpeg-win-2.2.2.exe”. Double-click on that to “Run” it.

This should open “Select Setup Language”. Click “OK”, then “Next”. Then read the information and click “Next”. Then “Select Destination Location”. Either use the default Destination Location or “Browse” to find what you want. I usually use the default, because it reduces the opportunities for problems later. To “Select Destination Location”, click “Next” again, then “Install”. After this completes (often less than a second), click “Finish”.

This worked as advertised on my Windows 7 machine. When I tried it on Windows 10, I got “A debugging check in this application has failed” when I next opened Audacity. I clicked “Continue” and got the same or a very similar message again. When I clicked “Continue” a second time, Audacity opened and worked as anticipated when I tried it.

1.2. for a Mac[edit]

Go to audacityteam.org. That landing page displays “Download” prominently in two places: The third dropdown menu item from upper left and a button in lower left.

Clicking “Mac” under either one should take you to audacityteam.org/download/mac, which recommends downloading Audacity 2.3.2 .dmg file (includes user manual). The third option there is “Audacity macOS DMG”. Click that, then select “Save File” and click “OK”.

Then go to “Finder” (the left most icon on my bottom status bar). One of the “Favorites” on my Mac is “Downloads”. Click that. The top option there will likely be “audacity-macos-2.3.2.dmg”. Double click that. When I did this just now, it ended with “Drag the Audacity.app icon to the Applications shortcut”. After I did that, I got an Audacity icon in Launchpad as well as under Applications in Finder that will start that version of Audacity any time I double-click on it.

Optional extension required to read Apple QuickTime .MOV files[edit]

As of 2019-09-12 the software that comes standard on an iPhone includes the ability to make movies in the Apple QuickTime .MOV format. By contrast, it is not as easy to find free software for an iPhone that will produce an audio file of an arbitrary length. Some applications seem to work fine with a short test but can turn off without warning before going over 60 minutes. This is unacceptable.

Fortunately a user can make a movie and extract the audio from it using Audacity 2.3.2, the recommended version as of 2019-09-12, but not without additional libraries that must be installed separately, because of different copyright restrictions in different countries. Reading this and other less common formats in Audacity on a Mac requires the installation of FFmpeg.

Instructions for this installation led me to https://lame.buanzo.org/#lameosx64bitdl. There find, “RECOMMENDED download:ffmpeg_64bit_osx.pkg”. Click on “ffmpeg_64bit_osx.pkg” and “Save File” by clicking “OK”.

Then go to Finder (typically the left-most item on the status bar at the bottom of the screen) and click on “Downloads” (typically the last item under “Favorites” on the left). “ffmpeg_64bit_osx,pkg” should be the most recent item at the top of the list if sorted by “Date Added” (typically the right-most column; you may need to scroll to the right to see that column, but you don't need that if “ffmpeg_64bit_osx,pkg” is visible).

Double-click on that. This will open a small window saying something like, “Welcome to the ffmpeg_64bit_osx installer ...”. Click “Continue” (lower right of that pop-up). You will then be asked if you want to “Change install location”. I usually accept the default install location, because that install location is virtually always better tested and less likely to have problems -- but change it of you feel a need. Click “Install” (lower right). It will then ask you for a password. If you do not have it, find the person who does have it for that computer. Supply the required password and click “Install” to proceed. It should flip through several steps ending with “The installation was successful.” Click “Close”. It will then ask, 'Do you want to move the “ffmpeg_64bit_osx Installer to the Trash?” Click “Move to Trash”.

Then start or restart Audacity. It should detect FFmpeg automatically.

1.3. for Linux[edit]

Go to audacityteam.org. That landing page displays “Download” prominently in two places: The third dropdown menu item from upper left and a button in lower left.

Clicking “Linux” under either one should take you to audacityteam.org/download/linux. That outlines different ways to install Audacity. Some versions of Linux include installers that include an easy install of Audacity.

2. Record material[edit]

EXERCISE: Pair with a person or persons next to you. At least one of you, preferably all, use some recording device of you interviewing your neighbor. You can use a voice or video app on your cell phone or some other device such as an audio or video recorder, e.g., a Zoom H4n, or a Sony Handycam. Please record you asking your neighbor the following:

2.1.1. Please state your name.
2.1.2. In 30 words, 15 seconds or less, please summarize why you came today.

Next, record yourself saying the following:

2.2.1. [Intro]: You are about to hear a shockingly brief interview with ____________ [say the name of your partner for this exercise, whom you just interviewed].
2.2.2. (pause)
2.2.3. [Break]: You are listening to a shockingly brief interview with _____________ [say the person's name again].
2.2.4. (pause)
2.2.5. [Outro]: You have been listening to a shockingly brief interview with ___________ [say the person's name again]. This is ______________ [say your name], reporting for 90.1 FM, KKFI, Kansas City Community Radio. [NOTE: The “90.1 FM, KKFI, Kansas City Community Radio” in KKFI's official legal ID. If you say “Kansas City's Community Radio” on KKFI's Program Associate's exam, you will flunk, because it's “Kansas City Community Radio”, NOT “Kansas City's Community Radio.]

The first part is a toy interview. The second part is Intro, Break and Outro, used to make that a complete piece, editing together with Audacity.

3. Transfer the recordings to a computer[edit]

If you already know how to transfer videos from your phone to that computer, please do what you know.

Otherwise, try the following instructions for either a Windows computer or a Mac:

3.1. Transfer to a Windows computer[edit]

3.1.1. Connect your phone to the computer with the USB charger cable that you use to charge your phone.
3.1.2. Unlock your phone and authorize sharing if requested. (This is require with my iPhone. It may be optional with other phones. I got a question like, “Allow access?” I clicked, “Yes.”)
3.1.3. Open Windows Explorer.
3.1.4. Look for your phone among the list of devices. For example, my phone was listed as “Apple iPhone” under both Windows 7 and 10. Click on that.
3.1.5. Search that directory until you find a directory containing the two videos you just created in step “2” above. For example, my “Apple iPhone” had a subdirectory “Internal Storage”. That had a subdirectory “DCIM”. That further had four subdirectories, “100APPLE”, “101APPLE”, “102APPLE”, and “103APPLE”. The most recent photos and movies were in the last one. To see the dates, I had to change the “View” to “Details”. Under Windows 10, this was available under a tab labeled “View” near the upper left, just right of tabs for “File”, “Home”, and “Share”. Under Windows 7, there was an icon near the upper right in Windows Explorer suggesting a list. When I hovered the mouse over the icon, it said, “Change your view.” There was a down arrow just to the right of that, which said, “More options,” when I hovered over it. I clicked “More options.” Then I found “Details”. In “Details” view, I searched the directory with the largest number in its name. There, I first clicked on “Modified” until it sorted the most recent to the top. Then I found the two movies I had just created.
NOTE: If Windows Explorer says the directory for that device is empty, return to step 3.1.2 and make sure you have unlocked your phone and allowed the PC to access the photos on your phone.
3.1.6. Select those two files.
3.1.7. “Copy”: This is most easily done with <ctrl>+C.
3.1.8. Go to another directory, where you want to put copies of those recordings. I suggest you create a new subdirectory wherever you want it to hold those files and other work related to this exercise. In Windows 10 Explorer, there should be a folder named “Documents”. In Windows 7 Explorer, I saw a folder labeled “Libraries” with a subfolder named “Documents”. Within that or within a subdirectory of that, I suggest you create a subdirectory for this work with a name like “AudacityTng2019-09-12”. You can create that by clicking in the directory in which you want to put this new subdirectory, then <shift>+<ctrl>+N. Then provide the name, e.g., “AudacityTng2019-09-12”, as just mentioned. I suggest you make the last 10 characters being today's date in YYYY-MM-DD format; see the discussion of ISO 8601 below.
3.1.9. Disconnect your phone from the computer. With my Apple iPhone, I just unplugged it. With other phones, you may need to <right-click> on the phone icon in Windows Explorer, then select something like “eject”.

3.2. Transfer a video from an iPhone to a Mac[edit]

3.2.1. Connect your phone to the computer with the USB charger cable that you use to charge your phone.
3.2.2. Unlock your phone and authorize sharing if requested. (This is require with my iPhone. It may be optional with other phones. I got a question like, “Allow access?” I clicked, “Yes.”)
3.2.3. Open Finder and select AirDrop. (It should be under “Favorites”. If you cannot find “AirDrop”, then I don't know: Do a web search for how to transfer movies or videos from you phone to the version of macOS running on the computer you have and ignore the rest of these instructions.)
3.2.4. Open your iPhone and select “Photos”. (On my iPhone it was the third from the left in the top row of four icons.)
3.2.5. If the videos you just made do not appear, select “Photos”.
3.2.6. Press “Select” in upper right.
3.2.7. Tap the two photos / videos you just made.
3.2.8. Tap the icon in the lower left that looks like a box with an arrow rising from the center of the box through the top.
3.2.9. This will open another window on your phone showing the items selected. Below that to the left should be another “AirDrop” icon. Tap that. It should first say things like, “Waiting” and “Sending”. After it's done, it should say, “Sent”.
3.2.10. Return to your Mac and its Finder. This time, click “Downloads”. (On my Mac, this is typically the last item in the top list under “Favorites”.
3.2.11. The two videos you just transferred should appear at the top of the list. The files I just transferred from my iPhone were named “IMG_3534.MOV” and “IMG_3533.MOV”. Select those two, e.g., by clicking the top one, then <shift>+<down arrow> to also select the second. Alternatively, clicking on one and then <cmd>+<click> should also work to select them both.
3.2.12. “Copy”, e.g., by <cmd>+C.
3.2.13. Go to another directory, where you want to put copies of those recordings. I suggest you create a new subdirectory wherever you want it to hold those files and other work related to this exercise. In Finder on a Mac, there should be a folder named “Documents”. Within that or within a subdirectory of that, I suggest you create a subdirectory for this work with a name like “AudacityTng2019-09-12”. You can create that by clicking in the directory in which you want to put this new subdirectory, then <shift>+<ctrl>+N. Then provide the name, e.g., “AudacityTng2019-09-12”, as just mentioned. I suggest you make the last 10 characters being today's date in YYYY-MM-DD format; see the discussion of ISO 8601 below.
3.2.14. Disconnect your phone from the computer. With my Apple iPhone, I just unplugged it. With other phones, you may need to <right-click> on the phone icon in Finder, then select something like “eject”.

3.3. Transfer Voice Memos from an iPhone to a Mac[edit]

3.3.1. Connect the iPhone to the Mac with a Lightning (connector).
3.3.2. In Finder (software) under "Locations", select the hard drive for your computer. Under macOS 10.14.6 on 2019-09-27 the hard drive appeared twice: directly as the second item under "Locations" and as the first subitem under the name of the user logged into that computer. A folder named "Users" is under that. And "Users" contains a folder with an abbreviated name of this user. That should contain a directory chain Music > iTunes > iTunes Media > Voice Memos. That should contain files with an "m4a" extension. The most recent voice memos you recorded should be at the bottom of that list.
3.3.3. After you've found the two files you want, click on one, then <Command>-click on the other.
3.3.4. Edit > "Copy 2 Items".
3.3.5. Navigate in Finder to wherever you want to store the copies of these files. This may be, e.g., Documents > current [if you have such a folder] and then some subfolder under that. On 2019-09-27 I had a subfolder "AudacityTng2019-09-12" to contain files associated with this exercise. I double-clicked that to get a Folder window containing only the contents of that folder. Then Edit > "Paste 2 Items".
3.3.6. Unplug your Lightning (connector) from either your iPhone or your Mac.

3.4. Transfer from Android phone to a Mac[edit]

[To be determined.]

Toy interview for teaching audio editing

3.5. Transfer to Linux[edit]

[To be determined.]

3.6. Download toy examples from Wikimedia Commons[edit]

Toy interview and "Intro-break-outro" audio files are available for downloading from Wikimedia Commons by first clicking the overlapping small boxes to the right of the caption for each file. Then click the *.ogg file name so it starts playing. Click the double vertical bar to the left to stop the audio from playing.

Toy intro-break-outro for teaching audio editing

Then File > "Save page as" [or a similar message depending on the Browser you are using] > [navigate to where you want to save the file].

Doing this for "File:AudioEditExample-interview.ogg" should give you a local copy of the "AudioEditExample-interview.ogg" file. Doing it for the second should give you a local file named "AudioEditExample-IntroBreakOutro.ogg".

4. Rename the files[edit]

In Windows Explorer on Windows or Finder on a Mac, find the folder into which you copied the two videos and rename the first one to “Interview.*”, where "*" is the extension, e.g., MOV for a movie on an iPhone, "m4a" for a voice memo on an iPhone, "MP4" for a movie from a video camera, "WAV" or "MP3" for an audio file from a voice recorder, etc.

On both Windows and Mac, you can rename the file by clicking gently on the name, possibly twice, waiting a roughly a second between the two clicks (so it's clearly not a “double-click”). Then the name will become clearly editable, and you can change it to whatever you want.

Or you can right-click (or ctrl-click on a Mac) and select "Rename".

Rename the second "IntroBreakOutro.*".

5. Start Audacity[edit]

5.1. If Audacity is installed on a Windows computer, clicking in the “Start” icon that is typically in the lower left will open a “Search” box. Start typing “Audacity”. The icon will typically appear after typing only the first three characters. Click it.
5.2. On a Mac, click on “Launchpad” near the lower left and search for “Audacity”. Or go to Finder and click “Applications”. This latter method can sometimes be easier, because the applications appear in alphabetical order. When you find an icon for “Audacity, double-click on it.

6. Read the recording into Audacity[edit]

6.1. File > Open
6.2. Navigate to the place where you stored copies of the two files, "Interview.*" and "IntroBreakOutro.*". On Windows 7, the “Open” window showed “Libraries” on the left with “Documents” being one of them. If you put the files you made under “Documents”, double click on that. I put it someplace else, so I had to click first on “Computer” to find that.
6.3. Select “Interview.*”, using the name you assigned above, and either double-click on it or select it and click “Open”.
NOTE: If FFmpeg is not properly installed, you may get an error message like, "Audacity did not recognize the type of file '...MOV'. Try installing FFmpeg." If you get this, make sure you installed LAME and FFmpeg as described with the installation instructions above. If FFmpeg for Audacity is installed properly, File > Open will import the audio track from a .MOV file, exactly as desired.
If this doesn't work for you, download the toy examples from Wikimedia Commons as described in section "#3.5. Download toy examples from Wikimedia Commons" above.

7. Select and Zoom to a part of a recording[edit]

Audacity has many features and different ways of using it. I prefer to select portions I want using the “Start and End of Selection” counters in the bottom of the Audacity window. With Audacity 2.3.2, the “Start and End of Selection” item can be changed to “Start and Length of Selection”, “Length and End of Selection”, “Length and Center of Selection”. I prefer “Start and End”. That allows me to delete or dramatically reduce the magnitude of an audio spike to the nearest thousandth of a second.

I manually enter numbers for the start and end times in HH:MM:SS.000 (hours, minutes, seconds and thousandths of a second). Alternatively, <ctrl>+A (or <cmd>+A on a Mac) selects all.

Clicking the button with a green right arrow will play the selection. Clicking the button with two vertical bars will pause the play.

The View menu has multiple “Zoom” options. I usually only use one: Zoom to selection. I get that by <ctrl>+E (or <cmd>+E on a Mac).

Sometimes I will do a gross selection, Zoom in, then do a finer selection to get the precise fractions of a second I want. I use this especially if I have a spike that is preventing me from amplifying a segment I want to make louder: I isolate the spike to the nearest hundredth of a second or so and adjust that, as discussed below.

There is a scroll bar at the bottom, which I sometimes use after I've zoomed into a selection just to make sure that I haven't left out part of what I want on one end or the other of the selection.

8. Delete an undesired part of the recording[edit]

To delete a portion of a recording, First select what you want to delete by specifying start and end of selection and discussed above. Verify that's what you want to delete. You can do this in multiple ways, e.g., first selecting a larger segment, then listening to it by playing it or part of it, and using the scroll bar at the bottom.

Then select Edit > Delete (or <ctrl>+K or <cmd>+K on a Mac).

I rarely bother shortening pauses unless they are so long they are distracting. Trying to save a half or a quarter of a second hardly seems worth the effort in most cases.

9. Zoom in on a spike and push it down to match a nearby sound level[edit]

Sometimes you get a spike that's so large its volume should be reduced. First select the problem period as outlined above. Then Effect > Amplify: Specify “Amplification (dB)” = -1 or -10 or whatever seems most sensible to you.

Then click “OK”. If you don't like that, use <ctrl>+Z (or <cmd>+Z on a Mac) to revert your changes and restart.

10. Amplify a portion of a recording that may be quieter than other parts[edit]

Select a portion of the recording that you want to amplify. Then Effects > Amplify. In contrast to when you want to push down a peak, you probably want to accept the default amplification by clicking “OK”. As before, if you don't like that, use <ctrl>+Z (or <cmd>+Z on a Mac) to revert your changes and restart.

Further discussion of using this and the previous step is avialable in "Audacity/Processing vocals".

11. Cut pieces from different recordings and paste them together[edit]

We assume now that you opened “Interview.MOV” above and still have it open. Similarly open “IntroBreakOutro.MOV”. When you opened “IntroBreakOutro.MOV”, it may perfectly cover “Interview.MOV”. Click on the Title bar and drag it to one side to expose the “Interview.MOV” that was covered.

In “IntroBreakOutro.MOV”, play the “Intro” part (“You are about to hear a shockingly brief interview with ___________.”) Press “Pause” (the icon with the two vertical bars next to the icon with the green triangle / arrow “Play” button). Then enter the end time in the space for “End of Selection” bottom right below the “IntroBreakOutro.MOV” recording. You may wish also to use a non-zero time for “Start”. You may wish further to View > Zoom > “Zoom to Selection” (or <ctrl>+E / <cmd>+E on a Mac) to confirm that you've selected what you want. Leave a half second or so before and after, so that segment does not begin and end too abruptly. After the “Start and End of Selection” reflect what you want, Edit > Copy (or <ctrl>+C / <cmd>+C on a Mac).

Next, File > New: This creates an empty space into which you can paste the snippet you just copied.

Now in that empty space, Edit > Paste (or <ctrl>+V / <cmd>+V on a Mac). The track you just pasted will be named “IntroBreakOutro” (upper left), even though it contains only the “Intro”. Click on that name. This should bring up a menu, the first item on which should be “Name”. Click that, then change the name to “Intro”.

Now go to “Interview.MOV” and first select the entire recording, then adjust the “Start and End of the Selection” to include precisely the material you want before the “Break”. Copy that bit, then click on the composite window and paste as before.

NOTE: If you cannot find the composite window, click Window > “Bring All to Front”.

The second paste operation should give you two tracks, one above the other. You can rename the second as you did the first, but I would not bother at this point.

Next, in the window with two tracks, Select > All (or <ctrl>+A / <cmd>+A on a Mac).

Tracks > “Align Tracks” > “Align End to End”.

At this point, you can listen to any part of it if you want just to convince yourself that you've done this correctly. (I often do that.)

Then Select > All again, then Tracks > Mix > “Mix and Render”.

Next, just for safety, and in case you want to close a half completed project to complete it later, do File > “Save Project” > “Save Project As”: Read the warning, then click OK. Give the project a name retaining the “.aup” ending. For example, in working this example while preparing theses notes, I named it “sbi2019-09-13.aup” for “shockingly brief interview” followed by the date in ISO 8601 format, as mentioned below.

Before clicking “Save”, be careful to make sure you store the project you are saving in the directory where you want it. Audacity, by default, puts it where you saved the previous project, which is probably NOT where you want it. Note that this save operation also changed the name of the composite window to the name you just gave for the project, “sbi2019-09-13” for my case just described.

That's it: You've now learned all the tricks you need to finish this exercise:

  • Return to “IntroBreaksOutro.MOV” and select the material you want for the Break, copy and paste it into the composite window, align tracks and mix and render, as before. File > “Save Project” > “Save Project” (or just <ctrl>+S / <cmd>+S on a Mac).
  • Return to Interview.MOV and select what you want for the rest of this interview, copy and past it into the composite window, align and mix and render, as before. (End with <ctrl>+S / <cmd>+S on a Mac to save your work to this point.)
  • Finally, return to IntroBreaksOutro.MOV” and select what you want for the Outro and combine that with the rest of the material in the composite window as before. (End with <ctrl>+S / <cmd>+S on a Mac to save your work, as before.)

12. Export as MP3[edit]

Once you have what you want, it's wise to listen to it (or at least listen to parts of it) to make sure it's what you want. Then in the composite window, File > Export > “Export as MP3”. Again before you click “Save” you need to change the directory to what you want, because Audacity by default stores it in the last place it stored an export file, which is probably NOT where you want it. Click “Save”.

Then you get “Advanced Mixing Options”, which are nothing in this case, especially if you were working with a mono (single channel) recording, which is what I got from using my cell phone. Other sources will have two channels. It's possible to get more. However, I've never had to worry about this, and we won't for this introductory class. Click “OK”.

Then enter “Artist Name”, “Track Title” and “Album Title”, etc., as you wish, and click “OK” again.

Then leave Audacity, find the mp3 file you made and play it -- or at least parts of it -- to convince yourself that you did what you wanted.

13. ISO 8601 international standard format for dates: YYYY-MM-DD[edit]

'Question': On “https://treaties.un.org/Pages/ViewDetails.aspx?src=TREATY&mtdsg_no=XXVI-9&chapter=26&clang=_en”, I read, “STATUS AS AT : 07-09-2019”. Is that July 9, 2019 or 7 September 2009? The short answer is that you can't tell just from looking at these few characters. If it was “07-13-2019” or “13-09-2019”, it would be clear. Different places use different standards.

There is an international standard for exchange of date- and time-related data, which says that dates should be written YYYY-MM-DD. It turns out that the date in this example is 2019-09-07.

This has the added advantage that a standard lexicographical sort puts dates in this format in the order you nearly always want.

See also[edit]

Audacity

Notes[edit]