Survey research and design in psychology/Tutorials/Introduction/SPSS

From Wikiversity
Jump to navigation Jump to search
Introduction to SPSS

Aim[edit]

The aim of this tutorial session is to (re)-familiarise participants with the SPSS software environment and to highlight some of its features which will be particularly useful during this unit.

Demo data file[edit]

Gnome-settings-background.svg View the accompanying screencast: [1]

The Microsoft Excel file (World95.xls) contains demographic data about people in 109 countries around the world in 1995:

  1. Gnumeric.svg Data file: World95.xlsx
  2. Save the file onto the desktop or a local drive/folder
  3. Open SPSS, then open the World95.xls data file:
    1. Change the Files of type: to Excel (.xls, .xlsx, .xlsm)
    2. Accept the default prompt about whether to 'read the variable names - yes, they are in the first row
  4. Once imported, the data file can be saved as a SPSS data file (File - Save As - World95.sav)

Learning outcome: Participants should understand that SPSS can be used to open many different data file formats, Excel being a common example.

Windows / file types[edit]

There are three main types of files in SPSS. Important features of these files are:

Data (.sav) Output (.spv) Syntax (.sps)
  1. Data view
  2. Variable view
  3. Inserting/deleting cases and variables
  4. Sorting
  1. Navigation bar
  2. Chart editing
  3. Table editing
  1. Pasting
  2. Executing
  3. Notating
  4. Saving
  5. Copying and editing

Learning outcome: Students should appreciate and understand that there are three files types in SPSS, each with their own purpose and functionality. To optimise use of SPSS, students should become familiar with viewing and editing each of the three file types.

Working with data[edit]

Gnome-settings-background.svg View the accompanying screencast: [2]

There are several data file manipulations that are commonly used and needed:

  1. Insert and Delete:
    1. Variables
    2. Cases
    3. Data
  2. Sort by a variable
    1. Ascending
    2. Descending
    3. Sorting by more than one variable
  3. Recode a variable to create a new variable
    1. Recode LIFEEXPF (Life Expectancy for Females) (a ratio variable) into LIFEXPFR, an Ordinal variable with
      1. 1 (Low) = < 70 years
      2. 2 (High) = 70+ years

Learning outcome: Know how to perform basic data variable and case manipulations in SPSS.

Working with output[edit]

Gnome-settings-background.svg View the accompanying screencast: [3]

Chart manipulation[edit]

Create a chart in SPSS (via Graphs e.g., a histogram of women's life expectancy) and then edit the chart until it is in APA style. Changes should include:

  1. Use monotone shading
  2. Remove default background (fill) and box (border)
  3. Edit the axis labels
  4. Remove descriptive statistics (legend)
  5. Graphs can be prepared in SPSS, Excel, MS Word (Insert - Object - Microsoft Graph Chart), or many other packages.

Learning outcome: Additional editing is generally needed to present figures in APA style.

Table manipulation[edit]

Generate a table (e.g., through Descriptive Statistics - Frequencies - LIFEEXPF) and edit to APA style, e.g.,

  1. Editing can be done in either in SPSS output or by copying into a word processor
  2. Often its easier to create a new table in a spreadsheet or word processing program

Important aspects of APA style tables:

  1. Gridlines: Only show horizontal lines above and below the header row and at the bottom of the table
  2. Meaningful row and column labels
  3. Correct statistical symbols
  4. Times New Roman 12pt font
  5. A title caption above the table
  6. Convey maximum (relevant) information in the most efficient and understandable way

Learning outcome: Know how to create an APA style tables in a word processing document.

Copying output to MS Word[edit]

  1. Right click on an SPSS Output Table or Graph
  2. "Copy"; treats the item as elements (which can be edited after pasting) - best option for Tables
  3. "Copy objects"; treats the item as a picture (not editable) - it will look as (almost) exactly as it does in the SPSS output - best option for Charts.
  4. In a MS Word document ctrl-v (to paste) (or choose Edit - Paste)
  5. Horizontally centre the Figure or Table
  6. Add an APA style Figure caption below the chart.

Learning outcome: Know how to copy an SPSS chart into a word-processing document and present in APA style, with a caption.

Working with syntax[edit]

Syntax is a powerful way of conducting SPSS data analysis:

  1. SPSS syntax files are text files which allows you to store, modify, and then re-run specific commands.
  2. Storing syntax is particularly useful when working over multiple sessions on a series of related analyses, particularly if you need to re-run the results.
  3. To open the SPSS syntax editor, File → New → Syntax. The SPSS syntax editor is an enhanced text editor.
  4. There are two ways to generate syntax:
    1. Use the pull-down menus to build analyses and then click "Paste". This will dump the command syntax into a (.sps) file. The syntax file can then be saved. To run the command, put the cursor on the command somewhere (or highlight it) and click on the green "Run" (play) button.
    2. Type SPSS commands directly into the syntax screen. This takes a lot to learn, but you can also copy and modify syntax.
  5. Annotate syntax files with lines which start an asterisk (*) and finish with a full-stop (.). That way you will be more easily be able to come back to the syntax file later on. e.g., * THIS IS A SPSS COMMENT - it starts with an asterisk and finishes with a full-stop.
  6. SPSS tutorial exercises will generally demonstrate use of syntax.
  7. See also
    1. SPSS → Help → Tutorial → Working with Syntax
    2. Using syntax
    3. Guides to working with syntax in SPSS lab manuals

Learning outcome: Understand the purpose and function of syntax commands in SPSS and have observed and experienced creating, executing, notating and saving syntax.

Help[edit]

To get help with SPSS, try the Help menu, particularly:

  1. Topics
  2. Tutorials
  3. SPSS Australia

Learning outcome: Students should become familiar with the help features available within SPSS.

See also[edit]