Blender3D

From Wikiversity
Jump to navigation Jump to search

This is an outline of knowledge necessary to be proficient at using Blender3D. This page is intended as a learning path, not as a comprehensive learning resource.

Primary sources[edit]

Please help to improve these primary sources.

User Interface[edit]

Grid Floor[edit]

You can change the grid size by going to

 Properties panel > Display

Look for the Grid Floor settings

  • X, Y, Z axes origins
  • Lines - number of lines to draw
  • Scale - how large the grid cells are
  • Subdivisions

Navigate[edit]

Change Windows[edit]

Quad View[edit]

Shortcut: Ctrl-Shift-Q

3D Space[edit]

Orthographic[edit]

3D Cursor[edit]

Cursor for performing objects such as adding geometry.

Select[edit]

Select individual objects using the right mouse button.

All[edit]

Shortcut A

Selects everything visible.

Box Select[edit]

Shortcut B

Draw a box to select objects. Any object that touches the box will be selected.

Circle Select[edit]

Shortcut C

Brings up a circle that you can use to draw a selection.

The radius of the circle can be changed by:

  • Scrolling the mouse wheel
  • Pressing '+' or '-' on the numeric keypad.

Viewport Shading[edit]

Viewport shading determines how Blender displays objects. It also has an effect on how you interact with objects in certain contexts. There are several viewport shading modes:

  • Texture - shows objects with their associated textures (high detail)
  • Solid - shows objects with shaded surfaces and shadows (moderate detail)
  • Wireframe - shows the basic geometry of objects (low detail)
  • Bounding box - shows rectangular boxes indicating the maximum extents of objects (lowest detail)

Manipulating Objects[edit]

Origin[edit]

Object menu > Transform >

  • Geometry to Origin
  • Origin to Geometry
  • Origin to 3D Cursor

Further Information[edit]

Pivot center[edit]

When Scaling and rotating, especially multiple selected objects, you can toggle between several pivot centers.

  • Active Element
  • Median Point
  • Individual origins
  • 3D Cursor
  • Bounding Box Center

Further Information[edit]

Blender 2.6 Docs: Pivot Point

Translate[edit]

  • Move objects in 3D space
  • constrain (x,y,z keys).

discreet numbers[edit]

  • properties panel
    • Transform
      • Location (X, Y, Z)

Note: Right click will cancel.

Transform Handles[edit]

3D Manipulator

Rotate[edit]

  • Rotate Tool (R key)
    • Constrain (X,Y,Z keys)
  • Hit R a second time, trackball rotation

Rotation Options[edit]

  • properties panel
    • Transform
      • Rotation (X, Y, Z)

Note: Right click will cancel.

Rotate Manipulator[edit]

  • 3D Manipulator -> Rotate Manipulator

Scale[edit]

Keyboard shortcut (s)

  • Constraint (X, Y, Z keys)

Note: Right click cancels scale operation

Scale Options[edit]

  • properties panel
    • Transform
      • Scale (X, Y, Z)

Scale Manipulator[edit]

  • 3D Manipulator -> Scale Manipulator

Flip or Mirror[edit]

To invert an object, simply scale past the origin. This will mirror the object.

Transform Orientation[edit]

The Transform Manipulator can be set to multiple orientations:

  • Global - overall scene orientation. Global X, Y, Z
  • Local - per object, relative orientation. May differ from Global X, Y, Z
  • Gimble - working with bones
  • Normal - aligned to the mesh surface normal.
  • View - move relative to view perspective

These options affect transforms, using different X, Y, and Z axes.

Snapping[edit]

You can precisely align and place objects using snapping.

Snap Elements[edit]

When manipulating objects, you can snap objects to various other elements. This is useful for modeling and alignment.

You can select which aspect of an object will do the snapping:

  • Volume - snap to bounding box
  • Face - snap to face
  • Vertex - snap object to verticies
  • Edge - snap object to edge
  • Increment - snap to grid

Objects[edit]

You can snap 3D objects to the grid or cursor.

Object > Snap
  • Selection to Grid - snap selected object(s) to the nearest grid division
  • Selection to Cursor - snap selected object(s) to the 3D cursor

3D Cursor[edit]

You can also choose to snap the 3D cursor.

 Object > Snap
  • Cursor to Selected
  • Cursor to Center
  • Cursor to Grid
  • Cursor to Active

Modeling[edit]

Mesh Primitives[edit]

shift + a will bring up the add menu. The following geometries are available.

  • Plane - two dimensional plane
  • Cube - three dimensional cube
  • Circle - two dimensional circle
  • UV Sphere - sphere with a grid similar to longitude and latitude. See [[w>UV mapping]]
  • Icospehere - sphere made out of triangulated surfaces
  • Cylinder - three dimensional 'tube', with end caps.
  • Cone
  • Grid
  • Monkey - Suzanne the monkey
  • Torus - basically a doughnut

Edit Mode[edit]

Edit mode will enable you to work directly with mesh geometry.

Press Tab to enter edit mode.

Selecting elements[edit]

There are three primary ways to select mesh components:

  • Vertex select
  • Edge select
  • Face select

Press control + tab to toggle between the selection modes.

Vertex Select[edit]

Vertexes are points of intersection.

You can move vertexes individually. Control handles will allow you to move the vertex relative to the world by default.

Select Normal on the Orientation menu. Normal will allow you to move a vertex relative to the surface normal of the object.

Edge Select[edit]

Edges are boundaries between faces.

Edge Loops[edit]

alt + right click to select entire rings of edges. These are called edge loops.

Loop Cut and Slide[edit]

You can add additional edge loops using the Mesh Tools toolbox.

  1. Press the Loop Cut and Slide button and hover the mouse over the mesh. A purple line will indicate the approximate loop cut.
  2. Left click to accept the approximate loop cut. The loop will turn yellow and you can slide the mouse to the precise location for the loop cut.
  3. Finally, left click to accept the loop cut.

Face Select[edit]

Lasso Select[edit]

Hold ctrl + left mouse button and draw a lasso around the elements you want to select.

Limit selection to visible[edit]

This button will toggle the ability to select geometry elements in two modes:

  1. only geometry on the visible surface
  2. include geometry on hidden sections of the mesh (the mesh will become semi-transparent)

Select More[edit]

Shortcut ctrl + "+"

Grows a selection to nearby elements.

Select Less[edit]

Shortcut ctrl + "-"

Shrinks a selection.

Proportional Editing[edit]

Proportional editing affects geometry elements that surround the selection. This creates smoother transitions along the edit boundary.

To enable proportional editing, use one of these methods:

  • Mesh menu > Proportional Editing > Enable
  • On the 3D View header, select a proportional editing mode

Vertex Groups[edit]

You can save selections as vertex groups. This enables you to quickly select previously selected vertices.

The keyboard shortcut is ctrl g

Sculpt Mode[edit]

Sculpt mode allows you to affect the mesh in a way that simulates sculpting.

Sculpt Tools[edit]

Various sculpt tools can be found under the Brush > Sculpt Tool menu.

  • Blob
  • Clay
  • Clay Strips
  • Crease
  • Draw
  • Fill
  • Flatten
  • Grab
  • Inflate
  • Layer
  • Mask
  • Nudge
  • Pinch
  • Rotate
  • Scrape
  • Smooth
  • Snake Hook
  • Thumb

Subdivision[edit]

In edit mode, you can add detail to a mesh by subdividing its geometry.

Select the mesh, and then click Subdivide in

 Mesh Tools > Add 

Number of Cuts[edit]

Adjust the number of cuts carefully. Each time you cut the mesh, you quadruple its complexity.

Smoothness[edit]

Smoothness will give the mesh a more natural, or organic feel.

Fractal[edit]

The Fractal settings will produce somewhat chaotic results. This can be useful for organic surfaces. The Random Seed will change the kernel that the fractal function uses, and may produce more or less desirable results.

Modifiers[edit]

Modifiers allow you to change an object mesh, and adjust your parameters at a later time. This flexibility is useful so that you do not have to alter your geometry until you are ready to apply the transformation. There are many modifiers in Blender, and describing the functionality of all of them may be beyond the scope of this curriculum.

Modify[edit]

  • UV Project
  • Vertex Weight Edit
  • Vertex Weight Mix
  • Vertex Weight Proximity

Generate[edit]

  • Array
  • Bevel
  • Boolean
  • Build
  • Decimate
  • Edge Split
  • Mask
  • Mirror
  • Multiresolution
  • Remesh
  • Screw
  • Skin
  • Solidify
  • Subdivision Surface
  • Triangulate

Deform[edit]

  • Armature
  • Cast
  • Curve
  • Displace
  • Hook
  • Laplacian Smooth
  • Lattice
  • Mesh Deform
  • Shrinkwrap
  • Simple Deform
  • Smooth
  • Warp
  • Wave

Simulate[edit]

  • Cloth
  • Collision
  • Dynamic Paint
  • Explode
  • Fluid Simulation
  • Ocean
  • Particle Instance
  • Particle System
  • Smoke
  • Soft Body

Lighting[edit]

Texturing[edit]

Animation[edit]

Rendering[edit]

Rigging[edit]

Simulation[edit]

Physics[edit]

Particles[edit]

Fluids[edit]

Game Design[edit]

See also[edit]